Announcement

Collapse
No announcement yet.

Atmel 128RFA1 users, RF200 series

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Atmel 128RFA1 users, RF200 series

    If using the Atmel 128RFA1 part to develop a SNAP device you need to be aware of a possible lock up condition that can occur if the following conditions are not observed:

    http://www.atmel.com/Images/doc8266.pdf

    Page 510 Section 35.6

    Vpot, Vpsr are of special importance. If these conditions are not met, the chip could latch up until VCC drops below 0.3V
    Attached Files
    Last edited by gvoce; 08-04-2014, 09:34 AM.

  • #2
    Enabling the internal BOD [brown-out-detector] will address the Vpot issue. Vpsr is fairly liberal, so it should not be a problem in most applications.

    Comment


    • #3
      @glitch

      This is above and beyond the simple BOD process. The voltage supplied to the Atmega IC must be brought all the way below 0.05 V or it will not properly reset (ie hangs in limbo). Even manually pulling the reset pin will not fix the issue (resides within the silicon).
      sigpic
      Proven Solutions for the Internet of Things
      www.synapse-wireless.com

      Comment


      • #4
        Perhaps I'm misunderstanding the problem then. What condition is actually happening to cause the chip to lock-up?

        Comment


        • #5
          It happens when Vcc drops down to near zero, but never gets below 0.05 V. Even if you apply Vcc again, the IC will not respond.

          If you bleed it all the way down, the IC (and Module) will start right back up once Vcc is reapplied.
          Last edited by Jheath; 07-03-2012, 03:20 PM.
          sigpic
          Proven Solutions for the Internet of Things
          www.synapse-wireless.com

          Comment


          • #6
            Originally posted by Jheath View Post
            It happens when Vcc drops down to near zero, but never gets below 0.05 V. Even if you apply Vcc again, the IC will not respond.

            If you bleed it all the way down, the IC (and Module) will start right back up once Vcc is reapplied.
            I see this has been fixed by Atmel in revF and above. Will new SM200 modules have the new silicon to fix this problem?

            Comment


            • #7
              Yes the RF and SM 200 series of modules will incorporate the new Atmel hardware that has this fix.

              Comment


              • #8
                @gvoce

                Are the current SM200s using the RevF Atmel parts? I have newer modules I'm working with and they are showing RevD (a return value of 4 for peek(349)).

                Comment


                • #9
                  Newer devices should be rev F or newer. There could be some rev D parts still in distribution such as yours.

                  Comment

                  Working...
                  X