Announcement

Collapse
No announcement yet.

Portal/Protocol backwards compatibility

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Portal/Protocol backwards compatibility

    Howdey Guys,

    is it possible to switch from portal 2.7 to portal 2.8 but only for some nodes within the mesh-network?

    wish you a nice day,

    Simon

  • #2
    All of the Portal versions so far have been fully backward-compatible; I regularly use the very latest (2.8.2) with old RF100 modules running 2.4.4 firmware.

    The one possible exception to this is if you think you may ever need to reinstall older firmware on nodes - each Portal version includes only the very latest version for each type of node, so you might want to save the older files before upgrading. They're in Program Files\Synapse\Portal\firmware.

    Comment


    • #3
      OK, this sounds good. Are "tested and working on old firmware" scripts also compatible with new firmware releases?

      Comment


      • #4
        Generally speaking, yes - probably the most likely problem is that the newer firmware version left less room for scripts, and your old script simply doesn't fit any more...

        This only applies to scripts in the original .py form - compiled .spy files are NOT usually compatible across firmware versions.

        Comment

        Working...
        X